Відкрити головне меню

Blender/Стартовий посібник (український інтерфейс)

< Blender

Цей посібник надає базові навички роботи з 3D редактором Blender версії 2.5 та вище. Основна мета - дати початківцям спробувати Blender на практиці, дати змогу відчути «смак» цього редактора.

Оскільки інтерфейс Блендера версій 2.5x досить сильно змінився порівняно з інтерфейсом версій 2.4x, даний посібник також знадобиться тим хто вже працював в Blender 2.4x і бажає перейти на версію 2.5x (або вище).

Зміст

НавігаціяРедагувати

Ми почнемо розглядати аспекти 3D, реалізовані в програмі, відразу з практики. Все про що нам варто потурбуватися зараз - це розташувати вказівник миші у потрібній частині інтерфейсу, яку ми називаємо область 3D-вигляду (і перевірити, чи включене додаткове поле клавіш (NumPad) на вашій клавіатурі).

Якщо у вас ноутбук (де зазвичай відсутня "цифрова" клавіатура), зайдіть в Файл / Користувацькі уподобання і там поставте галочку на Емулювати дод. клавіші.

Спробуйте понатискати клавіші, позначені червоним на ілюстрації:

Вони дають ефект наближення/віддалення та обертання по орбіті навколо центру об'єкта. Клавіша Numpad 5 перемикає між ортогональним та перспективним (конічним) виглядами. Коли переконаєтеся, що Blender справді є програмою 3D-моделювання, можете продовжити освоєння інтерфейсу. Рушимо далі і покрутимо коліщатко миші або натиснемо на нього і почнемо рухати мишею:

   

На що варто звернути особливу увагу - команда Файл / Вихід. При її виконанні Blender не запитує підтвердження або діалогу збереження сцени. Особливо небезпечним буде клацання по хрестику в правому верхньому куті вікна програми...

Строго кажучи, є спосіб відновити останні дані, але для цього вам доведеться самостійно знайти тимчасову теку Blender і визначити, який із файлів містить останні дані, записані перед закриттям програми. Є ще кнопочка Відновити попередній сеанс в меню Файл. Єдиний спосіб уникнути цієї незручності - виконати збереження до закриття програми.

Я користуюся Blender починаючи з версії 2.32 і досі не можу звикнути до відсутності попередження перед закриттям. Але маємо те, що маємо.

Основні елементиРедагувати

Ви потрапили в 3D простір, в якому є куб і щось на зразок сітки. Але що являють собою інші об'єкти?

Давайте подивимося:

Деякі назви говорять не дуже багато. Але ви шукали документ з основ Blender і хочете опанувати все швидко? Тоді давайте почнемо!

3D трансформаціїРедагувати

Віджети 3D-трансформацій було включено за замовчуванням у версії 2.49, але у 2.50 їх необхідно активувати для використання. Це можна зробити внизу області 3D-вигляду.

Вони дозволяють виконувати базове редагування об'єкта (переміщати, обертати, масштабувати). На початку ви переміщалися в 3D просторі, тепер переміщатися буде тільки об'єкт. Перетягніть мишкою одну зі стрілок навколо об'єкта.

Уявіть собі таке: Кадр 1 = початкова позиція, кінцева позиція = кадр 100 (і замість куба там космічний корабель, наприклад X-wing з "Зоряних війн" ... )

І не кажіть мені, що вам ще не починає подобатися вивчати цю чудову програму ...

Елементарні способи редагування об'єктів це: переміщення, обертання і масштабування. Ви вже знаєте як переміщати об'єкт уздовж осі, давайте спробуємо його повернути. Виберіть віджет обертання:

Будь-яка з кольорових дуг навколо об'єкта дозволить вам повернути його навколо відповідної осі. Після вивчення цих основних прийомів трансформації об'єктів пропоную поекспериментувати в такому порядку:

  • Опція трансформації, що залишилася неописаною - масштабування.
  • Ви можете поєднати всі віджети трансформації, утримуючи Shift при виборі кожного з них.
  • У всіх віджетів модифікацій є біле коло: якщо ви починаєте переміщати об'єкт, клацаючи по ньому, переміщення не буде прив'язуватися до осей.
  • Про випадне меню, де написано Глобальна, поки що можна забути.
  • Будь-яку незавершену дію можна скасувати натисканням на клавішу Esc або правою кнопкою миші.

Після випробування всіх віджетів ваша сцена має зовсім непередбачуваний вигляд. Тому ми виберемо Файл / Новий (Blender вилучить старий документ без збереження зроблених змін і відкриє новий зі стандартними налаштуваннями середовища). Зараз ви знаходитесь в стандартній сцені, створюваній при старті програми і ми поговоримо про камеру.

КамераРедагувати

У 3D-світі має існувати принаймні одна камера, щоб Blender знав звідки і з яким параметрами робити знімок сцени (наприклад, в якому форматі, png або jpg, зберігати зображення). Ви можете розглядати сцену в русі з будь-якої сторони, але як її бачить Blender? Вигляд з камери вибирають, натиснувши Numpad 0:

Прямокутник, описаний суцільною лінією, це сама камера, пунктирний прямокутник показує границі видимості камери (тобто те що ми будемо бачити в готовому кадрі). Давайте зробимо «фотографію» сцени. Найпростіший спосіб - натиснути F12 ... і ввввуалллляяяяя!

Це якраз і є результат вимальовування (англ. render) - зображення побудоване з урахуванням всіх зроблених вами налаштувань. Забудьте про ідею обертати сцену у вікні вимальовування. Це кінцеве зображення, кадр, таке ж як ви отримуєте роблячи знімки цифровим фотоапаратом.

Зауважте, що найбільш освітлені частини в сцені знаходяться прямо перед джерелом світла. У нашій сцені лише одне джерело (лампа), про це свідчить абсолютно чорна неосвітлена частина об'єкта.

Аж до версії 2.49 вимальовування відбувалося в окремому вікні. Але цю поведінку можна було змінити і зробити схожою на поведінку 2.50, де вимальовування відбувається в області редактора зображень UV, розгорнутій на все робоче середовище програми (не турбуйтеся, ми не збираємося вдаватися в технічні подробиці). Для повернення до робочого вигляду натисніть клавішу Esc (не клацайте по хрестику закриття вікна).

Панель КнопокРедагувати

Давайте розглянемо вміст розділу крайньої праворуч області. Тут є багато різних кнопок налаштувань. Розглянемо основні з них і постараємося отримати потрібний нам результат. Піктограми вгорі дозволяють перемикатися між різними розділами області кнопок. Цей розділ зазвичай вибраний під час запуску програми:

Ви вже знаєте що таке вимальовування, і вам буде досить просто розібратися в налаштуваннях цього розділу.

З наступних піктограм ми зупинимося на дев'ятій.

Якщо ви нічого не змінювали, то у вас в області 3D-Вигляду куб обведений рожевим кольором. Це означає, що цей об'єкт вибраний. І в розділі Матеріал ви побачите таке:

У цьому розділі нас цікавить панель Перегляд і закладка Розсіювання. Клацніть по колірному прямокутнику і відкриється редактор, в якому ви зможете вибрати бажаний колір та інтенсивність (змінюється обертанням коліщатка миші).

Можливий результат.

Ви, звичайно, можете розважити себе кількома вимальовуваннями (F12) з різними налаштуваннями матеріалу, але я думаю пора почати забувати про просту сцену з кубом. Поки куб виділений (обведений помаранчевим контуром) натисніть клавішу Delete та підтвердьте вилучення.

Додавання об'єктівРедагувати

Заздалегідь визначені об'єкти в 3D програмах називаються примітивами. Деякі з них являють собою прості геометричні об'єкти. А деякі можуть бути подарунком для програмістів, які готові експериментувати з програмою, але не займаються моделюванням. Перемкніть область 3D-вигляду на вигляд зверху (Numpad 7) і клацніть лівою кнопкою миші в центрі області. Це перемістить 3D-курсор в місце розташування вказівника миші.

Це важливо, тому що при створенні нового об'єкта Blender розмістить його саме в тому місці сцени, де розташований 3D-курсор. Саме час перейти до меню Додати / Каркас / Мавпочка.

Спробуйте покрутити і попереміщувати навколо сцени. Отримуйте задоволення від процесу:)

Цей об'єкт є талісманом програми і називається Сюзанна. Стривайте, час бігти і дзвонити своїм друзям з розповіддю про те, які чудові речі ви вмієте робити, ще не настав (не турбуйтеся, ви зробите це трохи пізніше).

Ви напевно захочете змінити колір матеріалу, як ми це робили з кубом. Але не лякайтеся, якщо при переході до розділу матеріалів ви побачите таке ...

... просто натисніть на кнопку Новий і перед вами відкриється весь набір кнопок, які були доступні при роботі з кубом.

А як же вимальовування? Не пропускайте цей етап, це задоволення за яке не потрібно платити:). Не турбуйтеся якщо у вас виходить щось таке:

Погана постановка світла та камери спричинили не зовсім зрозумілий результат вимальовування. Це трапилося через вилучення попереднього об'єкта і додавання Сюзанни без перевірки положення камери і світла відносно нього. Для виправлення ситуації нам потрібно перемістити і повернути Сюзанну за допомогою 3D-віджетів модифікації (наприклад, з вигляду з камери - Numpad 0). Постарайтеся домогтися гарного вигляду в камері і правильного падіння світла на мавпочку. Має вийти щось на зразок цього:

Правильніше буде повернути камеру. Можна повертати камеру вручну, але є два чудових способи. Спочатку просто поверніть вигляд за допомогою коліщатка миші так, як вам подобається, потім просто натисніть Ctrl + Alt + Num 0 - активна камера переміститься так, щоб показати саме той ракурс який ви обрали. Але можливо, деякі деталі опиняться поза прямокутником вимальовування. Врятувати ситуацію допоможе Shift + f. Якщо натиснути його з камери, ви перейдете в режим польоту: керуючи мишкою та клавіатурою, можна плавно переміщати камеру до тих пір, поки ви не натиснете ЛКМ, щоб застосувати нове положення камери і ПКМ, щоб скасувати переміщення.

Покращуємо зовнішній вигляд каркасу (англ. - mesh)Редагувати

У лівій частині інтерфейсу є ще одна чудова панель з кнопками. Ця панель стає видимою, або невидимою, за допомогою розділу меню Вигляд / Панель інструментів. Але набагато зручніше користуватися клавішею «T» (переконайтеся що вказівник миші знаходиться над областю 3D-вигляду).

Кнопка, яку вам слід натиснути, називається Гладко. Вигляд об'єкта значно поліпшиться:

Об'єкт перестав складатися з плоских граней (фасетний вигляд) і став гладеньким. Для повернення до фасетної версії об'єкта досить натиснути кнопку Пласко (але в нашому випадку це не потрібно).

Саме час активувати сьому кнопку в області кнопок - Модифікатори. Після додавання модифікатора Поділ поверхні стане доступним меню для вибору рівня поділу:

На панелі - кілька кнопок і полів з цифровими значеннями параметрів.

Подивіться на вашу модель і оцініть результат. Кожну грань поділено на 4 (ми не бачимо цього безпосередньо, але можемо оцінити ефект за більш гладкою формою і поліпшенням якості об'єкта).

Поле Вигляд: 1 стосується рівня поділу, який ми бачимо в області 3D-вигляду. У нашому випадку це рівень 1. Поле Вимальовування: 2 вказує рівень поділу, що використовується під час вимальовування об'єкта.

Причини появи цих двох окремих параметрів прості: більша кількість граней, створюваних при поділі більш високого рівня, вимагає більше ресурсів від вашого комп'ютера. Логічно було б працювати з меншим рівнем поділу об'єкта, а вимальовування здійснювати з більшим. Але врахуйте, практично ніхто не використовує рівні поділу більше 3 ні для роботи, ні для візуалізації.

Рівень поділу Вигляд рівний 2 поділить одну грань на 16. Спробуйте зробити вимальовування з рівнями поділу 2 і 3.

Ось і настав час подзвонити вашому братові або другові. Ви безумовно залишите його з відкритим ротом показавши свою роботу!

Керування виглядом з камериРедагувати

Перш ніж продовжити, я б хотів зупинитися на одній важливій речі. Найбільш зручний спосіб виставити потрібний вигляд для візуалізації - це обертати сцену і, вибравши найкращий вигляд, позиціювати камеру в цьому місці. Для цього є команда Вигляд / Вирівняти перегляд / Вирівн. акт. камеру за виглядом або швидкий спосіб - натиснути Alt + Ctrl + Numpad 0.

Один з можливих варіантів:

Зауважте, що контур камери став помаранчевого кольору. Це може мати кілька значень:

  • Команда вилучення (Del) призведе до вилучення камери зі сцени (не робіть цього, нам потрібна камера щоб мати точку вигляду для вимальовування зображення. Якщо все ж таки ви це зробили, натисніть Ctrl + Z, скасувавши цим останню дію)
  • Один з параметрів, який може вас зацікавити на даному етапі - керування фокусною відстанню камери. Цей параметр ми можемо знайти на панелі, що викликається з меню Вигляд / Властивості або після натискання клавіші N (при натисканні N вказівник миші повинен бути над областю 3D-вигляду). Параметр називається Лінза.

ВибірРедагувати

Як нам вибрати ще й лампу? У Blender вибір проводиться правою кнопкою миші і, як і в інших програмах, для вибору декількох об'єктів вам потрібно утримувати клавішу Shift.

На ілюстрації ви бачите три виділених об'єкти: камера, Сюзанна і лампа. Я думаю, ви помітили злегка різний відтінок помаранчевого по контуру різних об'єктів. Більш насичений помаранчевий колір позначає останній вибраний об'єкт (на цей раз це лампа).

Останнє зауваження особливо важливе. У більшості випадків останній об'єкт буде домінантним при виконанні різноманітних дій з групою об'єктів. Зараз ми не будемо загострювати на цьому увагу, але запам'ятайте це! Якщо ви зайдете в розділ Об'єкт, в області кнопок (див. нижче), ви можете побачити, який з вибраних об'єктів є домінантним. В даному випадку це об'єкт Lamp.

Але нас зараз цікавить не панель з кнопками. Ви можете помітити нову піктограму, схожу на спалах, яка дозволяє керувати світловою плямою:

Ви можете змінювати значення Енергія, вибрати колір світла (так само, як ми робили це з кольором матеріалу) або поекспериментувати з різними типами освітлення від різного типу ламп: Точка, Сонце, Прожектор, Півсфера або Площина.

Копіювання об'єктівРедагувати

Один або кілька виділених об'єктів можуть бути продубльовані командою Об'єкт / Дублювати об'єкти або сполученням клавіш Shift+D.

Ми використовуємо цей спосіб для створення в сцені схеми освітлення з трьох джерел світла (ламп).

Напевно ви помітили, що всі копії мають ті ж значення параметру Енергія і колір, що й початкова лампа.

Тепер виберіть всі лампи одну за одною, перемістіть їх, змініть параметри енергії та кольору (можна всі лампи зробити білими). Одне зауваження: постарайтеся зробити так, щоб сумарна енергія всіх трьох ламп була близька до 1.

Режим редагуванняРедагувати

Ми вже досить багато попрацювали з Сюзанною. Створіть нову сцену і ми скористаємося новим способом для зміни форми куба: режимом редагування. Найшвидший спосіб перейти в режим редагування - натиснути клавішу Tab, перевіривши, щоб куб був вибраний, і вказівник миші перебував у області 3D-вигляду.

Цей спосіб редагування дозволяє працювати окремо з кожною вершиною, кожним ребром і гранню. Вибирають вершини так само, як і в об'єктному режимі, клацаючи правою кнопкою миші (білий колір вершини означає, що вона вибрана). Виберіть вершину і перемістіть її (так само як і об'єкт, натиснувши клавішу G).

Я використовую цю можливість для деякого розширення знань про маніпуляції з об'єктами:

  • Якщо ви перемістите вказівник миші на біле коло 3D-віджета і «захопите» об'єкт лівою кнопкою миші за це коло, то об'єкт буде переміщатися в площині вигляду, в якому ви зараз перебуваєте (у площині монітора, якщо так буде зрозуміліше).
  • Клавіша G дає команду переміщати вибраний об'єкт у площині поточного вигляду (як в режимі редагування, так і в об'єктному режимі). Це означає, що відразу після натискання цієї клавіші об'єкт починає переміщатися разом з переміщенням миші. Доброю звичкою стане поміщати вказівник поруч з об'єктом, який ви хочете переміщати, до натискання клавіші G. Для обмеження переміщення об'єкта по певній осі, ми, після натискання на G, натискаємо клавішу, що вказує на відповідну вісь X, Y або Z. Спробуйте виділити дві вершини на одній грані, натиснути клавішу G й одразу за цим натиснути клавішу Z. При русі миші обидві вершини будуть переміщатися тільки вздовж осі Z (приклад на ілюстрації).

Якщо ви освоїли процедуру переміщення вершин, спробуйте покрутити їх за допомогою клавіші R і масштабувати за допомогою S. Обмеження дії по осях працює також і для цих типів редагування.

Якщо ви спробували редагувати кілька вершин, можливо ви відчули, що не все піддається контролю і переміщається або обертається туди, куди б хотілося. Не хвилюйтеся, ми будемо обговорювати це пізніше.

Опорна точка для обертання і масштабуванняРедагувати

Процедури обертання і масштабування безпосередньо залежать від точки, щодо якої вони проводяться.

За замовчуванням опорною точкою для цих операцій є центр об'єкта, позначений жирною помаранчевою крапкою.

Коли об'єкт з'являється в сцені його опорна точка знаходиться в геометричному центрі цього об'єкта. Якщо ми переміщуємо об'єкт в об'єктному режимі, його опорна точка так само переміщується. Але якщо ми перемкнемось в режим редагування, виділимо всі точки об'єкту і перемістимо їх, то зможемо помітити що опорна точка об'єкта залишилася на старому місці.

Ми можемо повернути її в потрібне місце, але іноді положення опорної точки поза об'єктом використовується з особливими цілями.

У попередньому випадку ми б зіткнулися з «неправильним» обертанням об'єкта при використанні віджета повороту в об'єктному режимі...

У режимі редагування положення опорної точки і об'єкта в більшості випадків не впливає на поворот і масштабування вершин, ребер і граней. За замовчуванням, всі операції проводяться відносно геометричних центрів вибраних елементів каркаса.

Для керування положенням опорної точки об'єкта в об'єктному режимі перейдіть на панель інструментів і натисніть кнопку Опорна точка.

З'явиться меню, яке дозволить вам вибрати один з варіантів дій з опорною точкою об'єкта):

  • Геометрію до опорної точки: переміщає об'єкт без переміщення його опорної точки;
  • Опорну точку до геометрії: переміщає опорну точку до геометричного центру об'єкта без переміщення самого об'єкта;
  • Опорну точку до 3D-курсора: переміщає опорну точку об'єкта в місце розташування 3D-курсора;
  • Опорну точку до центра мас: переміщає опорну точку до центра мас об'єкта.

Інші опції точок повороту вибирають у випадному меню, наведеному на малюнку:

На цьому етапі варто приділити особливу увагу експериментам для найкращого розуміння роботи інструментів Blender.

Витискання (extrusion): найпотужніша зброя 3D-моделюванняРедагувати

Ви вражені, чи не так?

Серйозно, те що сказано у заголовку розділу - чиста правда. Можна сказати, що розвиток 3D технології був би неможливий без механізму витискання. Не вірите? Переконайтесь самі.

Запустіть Blender і виберіть куб. У режимі редагування виберіть у куба одну грань. У вас є кілька способів зробити це:

  • Виділити вершини, що утворюють грань;;
  • Виділити ребра грані;
  • Виділити саму грань.

У нашому випадку я раджу скористатись останнім.

Для виконання операції витискання (так, я знову не розповів що ж таке «витискання», але я хочу зробити вам сюрприз), виберіть команду Каркас / Витиснути область, але я раджу скористатися гарячою клавішею E. Потім перемістіть мишу і завершіть операцію, клацнувши лівою кнопкою миші.

Якщо демонстрація цих можливостей не «зачепить» вашого друга, я готовий викинути рушник і здатися разом з вами.

Пограйтеся з вибором граней і їх витисканням. Зробіть що-небудь, схоже на реальні об'єкти. Насолоджуйтеся!

Ви вже повинні відчути себе комфортно при роботі з каркасом об'єкта.

Тут би я хотів трохи зупинитися і розповісти про дві речі:

  • Ви можете вмикати і вимикати напівпрозорість об'єкта, натискаючи кнопку праворуч від типу вибраного об'єкта (у нашому випадку грані).
  • Ви можете перемикатися між різними способами показу об'єкта. Один з них - каркасний. Вибір між ними здійснюється в цьому меню:

Два найбільш часто використовуваних при редагуванні способи відтворення об'єкта - Каркас та Суцільний. Перемикають їх, натискаючи клавішу Z.

Додавання каркаса на сцену, де вже є іншіРедагувати

Напевно ви скажете - «Це ж дуже просто! Потрібно зайти в меню Додати і вибрати потрібну форму з підменю Каркас».

Тут я хочу звернути вашу увагу на одну дуже важливу річ. Якщо ви додаєте каркас в об'єктному режимі - буде створено новий об'єкт, окремий від усіх інших. Якщо ж додати каркас у режимі редагування, то він стане частиною того об'єкта, для якого було увімкнено режим редагування. У прикладі нижче куб був доданий у режимі редагування UV-сфери:

Це означає, що:

  • обидва каркаси будуть мати спільну опорну точку;
  • ви не можете переміщати ці каркаси окремо в об'єктному режимі (при виборі куба буде автоматично вибрано і сферу, як і навпаки):

Всі властивості одного каркасу поширюються на інший. Взагалі-то, строго кажучи, нічого не поширюється. Повторю ще раз: обидва каркаси являють собою єдиний об'єкт.

Напевно вам би хотілося зробити ці два каркаси незалежними об'єктами. Давайте розділимо їх. Найзручніший спосіб це зробити - перейти у режим редагування і вибрати хоча б одну вершину каркасу. Вибрати команду Каркас / Вершини / Відокремити або скористатися гарячою кнопкою P. Blender попросить вас вказати критерії поділу об'єкта.

У даному випадку виберемо На окремі частини, що призведе до виокремлення всіх не з'єднаних частин.

Зворотна операція - об'єднання - доступна в об'єктному режимі. Виберіть об'єкти, які хочете об'єднати, і дайте команду Об'єкт / Об'єднати або натисніть клавіші Ctrl + J.

Вибрати всеРедагувати

Як у режимі редагування, так і в об'єктному режимі для вибору або зняття вибору з усіх об'єктів ви можете використовувати команду Вибрати / (Не) вибрати все але я раджу опанувати клавішу A.

Ще дещо про матеріалиРедагувати

Давайте знову повернемося до налаштувань матеріалів у області кнопок, і спробуємо з'ясувати, які ще їхні властивості ми зможемо змінити.

Я припускаю, що сцена перебуває у стані, в якому ми залишили її відразу після наших експериментів з поділом і об'єднанням. У нас два окремих об'єкти, але, оскільки раніше вони були одним цілим, вони обидва використовують один і той самий матеріал. При зміні налаштувань матеріалу для UV-сфери, так само зміняться налаштування матеріалу куба.

Перейдіть у розділ матеріалів і зверніть увагу на цифру 2 праворуч від назви матеріалу. Це кількість об'єктів, які використовують даний матеріал. Якщо ви клацнете по цьому числу, то для вибраного об'єкта буде створено окрему копію матеріалу, і зміна його параметрів не впливатиме на матеріали інших об'єктів.

Тепер, перейшовши в об'єктний режим, додайте площину і скомпонуйте об'єкти, як це показано на малюнку (у сцені використовується 3 джерела світла):

Після завершального вимальовування у вас має вийти малюнок, близький до цього:

Виберіть площину і перейдіть у розділ редагування матеріалів. Ми хочемо отримати дзеркальну поверхню і для цього нам потрібно знайти панель Дзеркало.

Першим кроком потрібно активувати її. Нам стануть доступні параметри для налаштування «дзеркальності» матеріалу:

  • Дзеркальність: ступінь віддзеркалення світла;
  • Френель: параметр, що використовується для матеріалів, нерівномірно дзеркальних по своїй поверхні (наприклад, скляний келих віддзеркалює тільки ближче до краю);
  • Звести до: Матеріал: зображення віддзеркаленого об'єкта переходить у колір матеріалу «дзеркала» (далі ми більш детально розглянемо цей параметр);
  • Глянець: параметр «чистоти» віддзеркалення. Робить об'єкт не зовсім реалістичним, але, як і раніше, дзеркальним.

Насолоджуйтесь новими можливостями. Пам'ятайте, віддзеркалення значною мірою відбиває світіння неба, і колір неба буде впливати на остаточний малюнок.

Тепер виберемо куб і в розділі матеріалів активуємо параметр Прозорість.

Нам будуть доступні такі параметри:

  • Трасування променів: прозорість, отримана за допомогою цього способу (не Z-прозорість), дає якісніше зображення і надає більшу кількість параметрів для імітації реальних оптичних ефектів. Але даний спосіб вимагає значно більших системних ресурсів (швидкодії процесора, обсягу оперативної пам'яті).
  • Альфа: ступінь прозорості
  • Показник заломлення: ступінь спотворення об'єктів при спостереженні їх через прозорий об'єкт
  • Глянець: дає такий самий ефект, як і при створенні дзеркальної поверхні

Я думаю, мені варто залишити вас на деякий час і дати можливість поекспериментувати з усіма цими чудовими параметрами.

Колір небаРедагувати

Спочатку колір неба сірий, але його можна змінити за смаком. Все, що потрібно зробити - вибрати колір, подібно до кольору матеріалу. Це роблять, вибравши розділ Світ в області кнопок:

Ще трохи про освітленняРедагувати

У попередньому випадку всі об'єкти відкидали по декілька тіней. Але, можливо, ви помітили, що не всі з трьох джерел світла створювали тіні у об'єктів.

Програма, що використовується для розрахунку всіх цих аспектів називається трасувальник променів (Raytracer). Для ламп, що випускають світло, але не створюють тіней від об'єктів, опцію Променеві тіні слід відключити. Ці функції ви можете знайти в області кнопок в розділі матеріалів при вибраному джерелі освітлення.

Якби у попередній сцені лише одне джерело світла створювало тіні від об'єктів, результат був би таким:

Значно краще. Але якщо подивитися на предмети в реальному житті, тіні втрачають контрастність на межі при віддалені від об'єкту. Отримані нами тіні виглядають занадто штучно. Для надання їм більшої реалістичності давайте змінимо параметри, що доступні на панелі трохи нижче:

  • Розмір розмиття - розмір зони розмиття;
  • Кроки - кількість тіней, які буде розраховувати Blender для заповнення зони розмиття.


Цей тип освітлення найближчий до часто використовуваного в 3D навколишнього світла (Environment lighting) та впливу оточення (Ambient occlusion), які не вимагають створення джерел світла (проте для отримання тіней додають одне або два джерела).

Але до застосування навколишнього світла нам потрібно вибрати кожен об'єкт, і в області кнопок в розділі Матеріали клацнути по хрестику поруч з назвою матеріалу, присвоєного цьому об'єкту. Вплив оточення підтримує і прозорість, і віддзеркалення, але час вимальовування буде значно більшим.

У цьому прикладі я вилучив всі джерела світла.

Для досягнення ефекту навколишнього освітлення нам потрібно в області кнопок зайти в розділ Світ і активувати Вплив оточення та Навколишнє світло.

Зверніть увагу на параметри:

  • Трасування променів та Приблизний. Приблизний метод краще використовувати для отримання ескізів сцени.
  • Кроки: навколишнє освітлення створює в сцені текстуру з шумом. Більша кількість кроків дасть більш згладжений шум.
  • Енергія: кількість випроміненого навколишнього світла.

Світло йде з усіх боків і створює дуже приємний естетичний ефект.

Процедурні текстуриРедагувати

Процедурна текстура - це текстура поверхні, але отримана не з зображення, а згенерована комп'ютером за певним алгоритмом (процедурою). У план цього опису не входить глибоке вивчення текстур. Тому я дам лише декілька підказок для самостійного освоєння цієї функції.

Почніть зі створення UV-сфери, згладьте її вибравши вид відтінення Гладко. Перейдіть у розділ матеріалів і призначте один для сфери. Це призведе до появи ще однієї піктограми праворуч від піктограми розділу Матеріалів. Цей розділ містить інструменти для додавання і створення текстур.

Коли ви клацнете по кнопці Новий, нижче з'являться параметри текстури. У випадному меню Тип, де спочатку вказано Хмари виберіть Мармур і ви побачите великий набір параметрів для налаштування.

Нижче - приклад результату вимальовування з увімкненим впливом оточення і дещо зміненим блиском:

Сірий відтінок з'явився від кольору матеріалу для сфери. Але призначена текстура використовує два кольори, тому замість другого кольору підставлено відтінок за замовчуванням. Вибрати другий колір ви можете у блоці кольору під кнопками налаштування текстури:

Виберіть другий колір подібним, але трохи темнішим від кольору матеріалу:

Саме час поекспериментувати з кольорами текстури і зробити декілька вимальовувань:

Ви можете додати декілька текстур до одного об'єкта.

Додавання колірних картРедагувати

Зараз ми додамо цю колірну карту на площину:

Створіть сцену і розмістіть об'єкти як на ілюстрації:

Тут одна горизонтальна площина, що моделює "землю" і одна вертикальна площина, на одну із сторін якої ми накладемо зображення.

Додайте вертикальній площині матеріал так само, як це описано вище. Але тепер у меню типу текстури виберіть не Мармур, а Зображення або фільм. Серед інших параметрів буде кнопка для виклику оглядача файлів для пошуку і завантаження зображення з вашої домашньої теки.

Перший результат буде таким:

Зображення може виявитися перевернутим через накладення на зворотну сторону площини.

Зробивши деякі налаштування текстур і матеріалів для обох площин і додавши навколишнє світло ви можете отримати, наприклад, ось такий результат:

Що вам слід знати про вимальовуванняРедагувати

На даний момент нас цікавить не дуже багато. У міру набуття досвіду багато речей стануть зрозумілими самі по собі. Давайте зараз подивимося на самі панелі Вимальовування. Перше, що ви тут бачите, і є найважливішим:

  • Вимальовування: еквівалент клавіші F12 - вимальовування зображення;
  • Показати: Повний екран. Вибір вікна, в якому буде відбуватись вимальовування. Найчастіше використовується Повний екран або Нове вікно;
  • Роздільність X, Y: розміри кінцевого зображення у пікселях;
  •  %: розмір вимальованого зображення, у відсотках від оригінального. Зменшуйте це значення для отримання чорнових варіантів і встановлюйте 100% для одержання фінального зображення з розмірами, зазначеними у полях Роздільність.
  • Згладжування: ступінь згладжування країв для того, щоб позбутись класичного ефекту драбинки. Більше значення дає кращу якість.
  • Альфа: якщо ми хочемо отримати зображення з прозорими ділянками, нам потрібно вказати, що колір оточення (колір неба і горизонту) не повинен з'являтися на фінальному зображенні. Спочатку потрібно вибрати формат фінального зображення PNG (або інший, що підтримує прозорість). Потім зі списку вибрати Прозоре.
  • Шлях до теки для збереження отриманого зображення зараз не дуже важливий - ми ж просто розважаємося.
  • PNG є форматом кінцевого зображення за замовчуванням, але ви можете вибрати серед великої кількості інших.
  • BW, RGB і RGBA: параметри вибору відповідно між чорно/білим, кольоровим і кольоровим зображенням з каналом прозорості (альфа-канал). Якщо ми хочемо отримати обговорюваний раніше ефект - нам потрібно вибрати останню опцію.

Якщо ви хочете зберегти створений малюнок, у вікні з вималюваним зображенням відкрийте меню Зображення і виберіть пункт Зберегти зображення або Зберегти зображення як..., як і в будь-якій іншій програмі, чи не так?

Важливі речіРедагувати

І ще декілька речей, які я вважаю важливими, перед тим як випустити вас у вільний політ.

  • Правильна організація послідовностей вершин має важливе значення при використанні модифікаторів (наприклад Поділ поверхні). Ці послідовності називаються «кільця». Для зміни форми наявного об'єкта використовуйте в режимі редагування інструмент Ніж. Для цього ви можете, як у випадку з керуванням опорною точкою, використати кнопку Замкнутий розріз і зсув, або просто натиснути Ctrl + R (саме цей спосіб я й рекомендую вам).

Коли ви клацнете перший раз по ребру, яке збираєтеся розрізати, Blender дозволить вільно переміщувати місце розрізу вздовж вибраного ребра.

  • Зазвичай, працюючи з об'єктами, ви орієнтуєтеся за глобальними осями координат X,Y, Z. Але об'єкт має ще й свої «локальні» координатні осі. Їх зручно використовувати, якщо ви вже повернули об'єкт і хочете пересунути або змінити його розмір відносно самого об'єкта. Для цього натисніть GYY (G - щоб дати команду переміщати об'єкт, Y два рази щоб переміщення відбувалося по локальній осі Y, спрямованій «вперед» по відношенню до самого об'єкту).

Це може допомогти і при 3D трансформаціях. Пам'ятаєте, я згадував на початку про випадне меню поблизу 3D-маніпуляторів?

Ви можете поекспериментувати з різними параметрами.

Є ще сотня речей, які я хочу вам розповісти, але я щоразу нагадую собі, що документ називається «Швидкий старт для новачків у Blender».

Хочу привітати, ви вже не новачки!

ЕПІЛОГРедагувати

Сподіваюся мені вдалося дати вам базові знання для початку роботи з Blender. Я не збрехав, коли сказав що цей посібник описує лише 1% можливостей програми. Blender підтримує анімацію, створення відеоігор, редагування аудіо та відео ... Blender вартий того часу, який ви витрачаєте на його вивчення. Це дійсно потужний інструмент, а не просто іграшка. Якщо ви опануєте Blender, у вас з'явиться можливість створювати будь-які графічні роботи, обмежені лише фантазією.

Вітаю вас зі знайомством з цим чудовим новим світом і ... Щасливого Blend'ингу!